Impact

This forum is read only and just serves as an archive. If you have any questions, please post them on github.com/phoboslab/impact

8 years ago by heyjanow

I tried running it on a device running iOS 4.0 and I get a bad access in loadScriptAtPath on this line.


JSEvaluateScript( ctx, scriptJS, NULL, pathJS, 0, &exception );

How do I resolve this problem? Works fine in simulator.

8 years ago by vetie

Sorry to bring up an old thread but I having the same problem that stahlmanDesign was having when importing the iosimpact.xcodeproj into Xcode where it cant find the JavascriptScore/JavaScriptCore.h file.

I have done all that Dominic suggested in this thread (removing the quotes in the header file and then checking the path and selecting "Recursive" checkbox, doing a "clean") but I still cant get it to find the file. I even re-downloaded it and tried it but no joy. I should be able to build for the simulator correct? And not just a device.

I am using the xcode 4.2 with the latest iosImpact Xcode project. Anyone else have some ideas that I could try? Just purchased the engine and would love to get something put on my iPhone

8 years ago by paulh

I just had the same issue, had a space in one of my folder names?

8 years ago by vetie

I appreciate the feedback paulh, that corrected my issue.

I had almost given up on this framework and asked for a refund because I had received no responses to my inquiry and couldn't get anything to run in the simulator.

I am now able to run the demo, JumpN Run within the IOS simulator.
Thanks
Page 2 of 2
« first ‹ previous next › last »