This forum is read only and just serves as an archive. If you have any questions, please post them on

1 decade ago by bugzilla

I just downloaded the Ejecta sample project and attempted to build it using Xcode (4.6). I always get the error message:

"Lexical or Preprocessor Issue: JavascriptCore/JavascriptCore.h"

I figure Xcode can't compile the JavascriptCore files. Anyone know how to fix this? I've looked everywhere for a solution but nothing exists. I have tried Cleaning the Xcode project as well as the other normal Xcode build issues. Nothing works.

1 decade ago by bugzilla

This is very strange. I was able to compile the Ejecta Xcode project fine....with one caveat. It will not compile if the Ejecta project is in a subfolder. For example, I keep all my IOS programs in a certain folder. If I drag the Ejecta file into there it won't compile. If I leave it on the Desktop it compiles fine.

Weird. Any idea why that is?

1 decade ago by Joncom

Possible that the path is too long when you move it to a different folder?

10 years ago by Sven

I had the same problem, fixed it by renaming the parent folder. I had a space in the name, replaced it with a dash. I guess it doesn't like spaces or maybe more characters that need escaping in its path.
Page 1 of 1
« first « previous next › last »