This forum is read only and just serves as an archive. If you have any questions, please post them on

7 years ago by Olli0979


since yesterday evening I get an error at the weltmeister editor. Yesterday morning all was fine. I wanted to create a new entity. Now I can't get in there. The game runs normal. I tried to delete the entity js, but the error is still there.

I read about problems with AdBlock Plus in another thread, but this is not the problem here. I tried different browser, os, but nothing helped.

Does anyone knows this error?

Thanks in advance!


ajax — jquery-1.7.1.min.js:4:14014

SyntaxError: JSON Parse error: Unexpected comma at the end of array expression

ajax — jquery-1.7.1.min.js:4:14014
load — weltmeister.js:313
init — weltmeister.js:139
Class — impact.js:538
end — weltmeister.js:984

7 years ago by Joncom

By default, Weltmeister loads all the entities in your "entities" folder so that they can be used in the editor. If one of your entities has some bad JavaScript, that can mess up the editor too. Does one of your entities use JSON.parse somewhere in its init function?
Page 1 of 1
« first « previous next › last »