Impact

This forum is read only and just serves as an archive. If you have any questions, please post them on github.com/phoboslab/impact

6 years ago by eLouai

Error message when running in Mac Chrome version:28.0.1500.71
"Uncaught Failed to load resource: media/sounds/Pickup_Coin_01.mp3"

This is when I created and converted the audio file from wave to mp3.
At first I checked and rechecked the spelling, I did not even trust the ascii code, assuming maybe a unicode character 'P' or 'i' that LOOKS the same but is not the same character as stored on file, retyped but no, was all good.

Then I tried the sample sounds I received from impactjs and it worked, so I thought it must be a format issue, did half a dozen formats encoding using Adobe Audition from .wav to .mp3. But no, it still did not work.

Finally I said, what the heck, let me try it on Safari ... and it worked!

Confused, Chrome is up to date, so how do most of you create or generate sound files? And does it work right off the bat on Chrome (for the Mac)?

6 years ago by Joncom

Lower the bitrate or some-other-way reduce the filesize of the audio.
Chrome doesn't like large audio files.
At least, in my experience, that has been the reason.

6 years ago by eLouai

Found the problem
Please Dominic, add to bug fix, had me stumped for 3 days.
For others who get this bug , this is what you do ...
(thanks JonCom for your suggestions, will keep that in mind)

Open
lib/impact/sound.js
Go to the bottom of the page
Change the order of file formats loaded from
ig.Sound.use = [ig.Sound.FORMAT.OGG, ig.Sound.FORMAT.MP3];
to
ig.Sound.use = [ig.Sound.FORMAT.MP3, ig.Sound.FORMAT.OGG];

That fixes the problem.

Thanks to this thread
http://impactjs.com/forums/help/loader-stalls-on-ig-sound-for-music-file

6 years ago by DanielGray

Having a similar issue with the web-version of the game not loading sounds when it is baked. getting an uncaught sound loading error for every sound. Everything runs locally and it even runs in the chrome web store, which I'm not sure what is going on that it won't run without being in the chrome web store, trying this fix.

6 years ago by Joncom

Everything runs locally and it even runs in the chrome web store
So where is it not running properly then?
Page 1 of 1
« first « previous next › last »