This forum is read only and just serves as an archive. If you have any questions, please post them on

1 decade ago by ArcadeHype

I have a bunch of images that i am loading and drawing in my impact game and they render fine in a web browser but for some reason they don't appear on my iphone 3gs or iphone 6 simulator.

I am using new ig.Image('media/image_name.png') to load my images but it doesn't seem to work in Ejecta.

My entities on the other hand render fine but they are being loaded with
new ig.AnimationSheet('media/image_name.png');

I guess my question is does new ig.Image('media/image_name.png') work in Ejecta?

UPDATE: some of my images are actually rendering but not all of them. Is there a limit to how many images can be loaded or displayed?

1 decade ago by dominic

There's of course a limit for the number and size of images you can load. The memory limit for the iPhone 3GS seems to be about 20-25mb. That's roughly a single 2560*2048 pixel image, or lots of smaller ones.

However, Ejecta should actually respond with calling onerror instead of onload on the image if it fails to create a texture for it; Impact's pre-loader should never finish. I'm not sure what's going one there.

What makes this strange in your case, is that it's not working on the Simulator either - and the Simulator doesn't have the same strict memory limit as the iPhone. Maybe it's the image format somehow? Are they PNGs? Maybe they're corrupt or saved in a way that the PNG loader doesn't like.

Could you upload one of the images that doesn't work, so I can have a look?

1 decade ago by ArcadeHype

Hey Dom,

As i mentioned everything is loading fine in Ejecta/xCode and the game is loading past the preloader in the simulator and on my iphone - its fully playable. But again certain images are simply not rendering.

Here is one of the images that is not displaying:

I save all my PNG files using Photoshop's "Save For Web" feature with PNG-24 and transparency enabled. Feel free to inspect it and see if there might be something wrong with it.


1 decade ago by dominic

I just tested your intro_logo.png in a tiny Impact sample App and it works just fine on the Simulator and iPhone4s.

I have no idea what's causing this. At the very least, Ejecta should respond with an error in the console.

If you want to, you can send me your App folder via email and I'll have a closer look.

Edit: Solved. An undefined value was ignored by the Browser, but interpreted as 0 by Ejecta.

1 decade ago by noGrip

Hi Dominic,

I'm having the same problem and downloaded ejecta yesterday.

I have a really simple game with just 3 entities (tower, zombie and bullet) and a background image, just to try out with ejecta. After I run it in the ios simulator (6.1), only the tower and the bullets are rendered. The zombie is just a white square.
All images are .png, have no idea what can be going wrong.

Any ideas?

Thank you


1 decade ago by noGrip

Ok, found the problem:
zombie[3936:2203] Warning: Image /var/mobile/Applications/1DD6E84D-F903-483D-BD21-1C1CD24907B9/ larger than MAX_TEXTURE_SIZE (2048)

the sprite sheet is too big!

Thank you anyways

1 decade ago by superprat

So There's a maximum sprite sheet size for Ejecta? Any way around this?
Page 1 of 1
« first « previous next › last »