Impact

This forum is read only and just serves as an archive. If you have any questions, please post them on github.com/phoboslab/impact

9 years ago by 80bit

First, I just wanted to say AMAZING JOB, I am very new to game development, but i was excited to get into things the instant I saw the engine explained in your video all those months ago.

I'm having a problem with saving my files from the weltmeister editor, when i try to save, I get "Error: Couldn't write to file: ../../../lib/game/levels/test.js" coming up.

I realize this may be a simple thing, I am running the game itself from http://localhost/pong and wanting to edit the map. Let me know if you require any more details.

Again, thanks so much. I assure you, the best $100 I ever spent. My life has changed...

9 years ago by dominic

This error usually appears if PHP does not have the permissions to write the file.

I guess you're on OSX? Just open a Terminal and give write permission to the levels directory:
chmod -r 777 /path/to/your/webserver/pong/lib/game/levels

Hope that helps!

9 years ago by 80bit

That did the trick - thanks!

9 years ago by ape

Just wanted to drop a note here for those who might not be familiar with chmod on OSX. If you run the command above, you're likely to see:

chmod: 777: No such file or directory

Change the lowercase -r to an uppercase -R:

chmod -R 777 /path/to/your/webserver/pong/lib/game/levels

8 years ago by Ash_Blue

I just ran into this problem via Windows with WAMPServer. Since my files were on a secondary internal HD, I had to give my username full permissions for the HD. Hopefully useful to someone else who has this problem.

8 years ago by stahlmanDesign

This happened to me several times when I downloaded Impact and you don't have to use the terminal in OSX. Just select your sites folder, cmd-i, uncheck the padlock and change the privileges to read and write. Then click the gear icon and choose to apply to all folders.

8 years ago by munho

I seem to be having a problem with this issue. I'm on a Windows 7 box. I'm going the the "pong" video and I'm creating the level in Weltmeister. When I go to save I get a popup that just says "Error:" and nothing else. I changed the permissions and I still get the error. Help?

8 years ago by munho

It's probably also worth noting that when I was looking for my files in the "Tileset" box, it only says "...parent directory" so it's not seeing the tileset file either, though if I just type it in I can use spacebar to pull up the set and paint.

8 years ago by munho

Ok, I figured out the initial issue. It was a noob mistake, but I wasn't pointing to http://localhost in my browser and as soon as I did Weltmeister started working.

But now, when I try to setup my layers Weltmeister won't respond. I click the "+" to add a new layer and it doesn't do anything. I've made all the code changes along with the Pong video and I'm to the part that creates the levels in Weltmeister.

Not sure what the issue is now. Any help is appreciated.

8 years ago by munho

Dammit! I just figured it out by using Firebug. Turns out I was missing a colon after a requires. Dumb dumb dumb. Thanks anyway.

8 years ago by Blake

I am having a problem saving on a Mac from Weltmeister, too.
Weltmeister seems to be running. I can add layers, etc. Saving, however gives me an alert that says "Error: " and no details.

I have set all the permissions to read & write, and also gone through with the
chmod -R .... in the terminal, and re-cursed through all the directories in the imapct folder, so I don't think it is a permissions issue.

Apache and MySQL are running fine.

Any suggestions? Thanks for your help, I am excited about using ImpactJS!

8 years ago by Blake

I might also mention when I run firebug I get this error in the console, although there is a main.js is in the game folder not in the levels folder...

"The requested URL /impact_learn/lib/game/levels/main.js was not found on this server."

I moved the main.js to the levels folder and although the above error goes away, I still get the Error: message upon saving.

Where does the main.js file belong and how do I save my work in weltmeister?
Thank you!

8 years ago by dominic

Blake, my guess is you've used Weltmeister for the Pong demo game, where there is a lib/game/levels/main.js. Weltmeister remembers the last loaded level file and tries to load it again when you start it. If this file is not present, WM will simply abort loading this level and throw the error.

The fact that this error message reappears when you save a level, seems to be a bug in WM. I'll fix this in the next version. You should still be able to save and load levels like normal - just don't worry about the error message.

If this problem persists, try setting the loadLastLevel property in your lib/weltmeister/config.js to false.

8 years ago by Blake

Wow, Thanks for the superfast reply!

I am working along with the pong demo, but was using a fresh installl of impact from my downloads page with my own graphics.

Changing the loadLastLevel to false did eliminate the file not found errors. Thanks.


Welt still throws the "Error:" alert when I 'save' and 'save as'. I am pretty certain that isn't saving the levels because they aren't appearing in the levels folder, and I can't load them either.

Any idea of a quick fix, alternately whendo you anticipate the next version will be out? I work at a university and we are considering using ImpactJS for several paleontology outreach applications- (ie fossil dig games for kids), It will be a fun project and based on what I have read ImpactJS will be great, but I have to be able to save on it before we move ahead. :) It's an amazing product and I am very excited to use it.

8 years ago by Blake

Thanks for the help, Dominic.
What Dominic had me do was test to see if I could pull up the php info from my local server and I could not, so the problem was not with Impact at all.

Even though MAMP was giving me two "green lights," I had not set the server up correctly on my Macs. I had problems with this on two separate computers.

In one case the private/etc/apache2/httpd.config file needed to be modified to enable php, I also adjusted the php.ini file. Both are described here, a bit old, but it worked:
http://foundationphp.com/tutorials/php_leopard.php

Also: I made certain that the MAMP was pointing to the same root as my localhost.

In the other case, the httpd.config file was actually corrupted, so once that was fixed, I was able to go through the same process and get Weltmeister running just fine.

8 years ago by UltimateBrent

Should probably just link that tutorial in the docs. It's a very thorough walkthrough on how to turn stuff on, and it holds up for Lion as well. The process hasn't changed.

The only thing it misses that you'll probably have to do is set file permissions.

8 years ago by CoYotE

Hey there. I read this threat several times now and still have problems in weltmeister including the "save/save as"-option.

Fast description of System used and problems caused:


Mac OS X - version 10.6.8
2.53 GHz Intel Core i5
4 GB 1067 MHz DDR3


Apple Safari 5.1.2 -> Weltmeister Editor is not working

Firefox 10.0.2 -> Weltmeister Editor is working, but "save/ saves" causes an error even tho "lib/game/ levels" is set to "read&write" and I am pointing
to "localhost" in my browser.

Also the Dropdown-Menu Tileset is
not working. Typing in the source manually
only works sometimes.

Google Chrome 17.0.963.66 -> Weltmeister Editor is not working


Any further suggestions? Anyone ?!

Cheers,
CoYotE

8 years ago by JoshuaSullivan

Are you sure you have PHP working properly? It seems like this is the most common obstacle, along with directory permissions.

Try creating a file named "test.php" in ~/Sites/ with the following contents:

<?php phpinfo(); ?>

Save it and open "http://localhost/~[USER]/test.php" in a browser, where [USER] is your user name.

8 years ago by CoYotE

thnx for reply.
sry I'm a bit late.

Yes I am sure my php should work properly.
After checking again and pointing to welt exactly from localhost.
Now the Editor works much smoother. Esp. in Google Chrome.
Dropdown-menus are available now and entities as well. ! Great.

But I still can't save the file.
In any supporting Browser I've tried o far.

I'll try this now with creating the test.php, and see if this works.

8 years ago by CoYotE

I am getting a big page with loads of stuff and there.
- title says "php version 5.3." - it shows my system underneath and many other all component settings and stuff as well.

So that shows me that my php works properly right ?

8 years ago by CoYotE

ah sry: php page says: "php version 5.3.1" -> if that matters.
Cheers

8 years ago by CoYotE

Hey!
Finally got it to Work ! Great !
Now I am enjoying the full Awesome Editor !!
Thnx Folks

CoYotE

7 years ago by eruciform

Another thing to watch out for is symbolic links. If for some reason lib/weltmeister/api/../../..lib/game/levels is not the same as what you think lib/game/levels is, then it will fail, as the api/save.php program doesn't know where the original weltmeister.html file was located.

This hit me because I had multiple project directories, each with their own lib/ directories, but I had a symbolic link as lib/weltmeister/, pointing to a shared version, so I didn't have lots of copies lying around. Killed me. Ugh.

7 years ago by fugufish

also, if the levels folder doesn't exist, you'll run into this problem.

7 years ago by fugufish

also, if the levels folder doesn't exist, you'll run into this problem.
Page 1 of 1
« first « previous next › last »