Impact

This forum is read only and just serves as an archive. If you have any questions, please post them on github.com/phoboslab/impact

1 decade ago by thenadamgoes

I've loving biolab on my iphone.

But when I try to play it on my android (Incredible). The game loads and runs fine except that the buttons don't register two presses at once.

I have to stop running to jump or shoot.

I'm wondering if this is a limitation of the browser or the game engine.

thanks!

1 decade ago by dominic

As far as I know, that's a limitation of the Browser. I don't have any Android devices to test it, though.

Edit: Yep, Even multitouch Android supports only one touch at a time. :/

If you find a workaround or a web app where you can use multitouch on Android, please let met know.

1 decade ago by fugufish

definitely a drawback of making html5-based apps vs native apps, but hey, I can't complain.

if you're into using Appcelerator's Titanium, here are some resources for reading

http://developer.appcelerator.com/question/41381/multitouch-support
http://developer.appcelerator.com/questions/tag/multitouch
http://developer.appcelerator.com/question/60921/multi-touch

someone made a multi-touch module on GitHub
https://github.com/masuidrive/TiMultitouch

1 decade ago by Bugninja

I experience the same thing on all my Android devices. The game runs fine, but no multitouch. Galaxy Tab and G1.

1 decade ago by stratman05

Android does not expose the multi touch parameters in the web browser, but iOS does.

And the appcelerator link is for iOS only. It's pretty much up to Google and the Android team to develop multi touch into the native browser.

1 decade ago by xdissent

I want so badly to troll Android fanboys with this information. =)

1 decade ago by stratman05

This really isn't anything to troll about. It's only in the web browser. Android still has access to multi touch in native applications.

1 decade ago by xdissent

Eh, I respectfully disagree. You read "It's only in the web browser" differently than I do I guess - seems like the single most important app on a mobile device to me. Meanwhile iOS 4.3 just dropped with the Nitro JS engine in MobileSafari, making it 2.5x faster than 4.2's version (great news for Impact). Seems like Android could use some browser love.

1 decade ago by dominic

To be fair, iOS also had some Multitouch issue recently.

I haven't installed 4.3 yet, but it should be fixed. Will report later :)

1 decade ago by dominic

The Multitouch issue is still not fixed in iOS 4.3 - I reported that bug 5 month ago :/

The speed for Biolab Disaster is also exactly the same as it seems. Around ~35fps on my iPhone 3GS. It's still the rendering performance that's holding it back, not the JavaScript engine.

1 decade ago by xdissent

Dom, did you report the bug through https://bugreport.apple.com or through Webkit's BugZilla tracker? You should keep track of bugs you report and maybe mention them on this forum so the rest of us can report them as well. Apple supposedly tackles issues based on number of reports so hopefully we can speed up the fixing process.

1 decade ago by dominic

I did. Here's their response from a few days later (Dec 3rd 2010):
This is a follow up to Bug ID# 8695599. After further investigation it has been determined that this is a known issue, which is currently being investigated by engineering. This issue has been filed in our bug database under the original Bug ID# 8632149.


I hate non-public bug trackers. Filing bugs for Apple and Opera is just an awful experience :/


Edit: Here's my original bug report and the "discussion" that followed. Feel free to resubmit it to annoy them some more; they deserve it :D

23-Nov-2010 04:18 AM Dominic Szablewski:
Summary: In the browser, when touching the screen with one finger, the JavaScript touchstart event for a second touch is only recognized after a finger is moved.

Steps to Reproduce:
Visit the this site and follow the instructions:
http://www.phoboslab.org/crap/mt.html

Expected Results:
The touchstart event should immediately be triggered when touching an element with the event handler

Actual Results:
The touchstart event is not triggered at all or has a serious lag ( > 1s)

Regression: Worked fine for iPhone 3GS with iOS 4.1 and is broken for the iPad and iPhone with iOS 4.2.1


02-Dec-2010 07:02 AM Patrick Collins :
Engineering has requested the following information in order to further investigate this issue:

Could you please attach your device log to the bug report. Device logs can be retrieved via the Organizer in Xcode. Or, from the iPhone/iPad Configuration Utility:

1. Download and install iPCU from http://www.apple.com/support/iphone/enterprise/
2. Launch iPCU, then connect device with USB cable
3. Click the Console tab in iPCU
4. Reproduce the problem
5. Click the “Save as” button to save the log to a text file.
6. Attach the text file to the bug report



02-Dec-2010 12:56 PM Dominic Szablewski:
Starting the browser, loading the page with the test-case ( http://www.phoboslab.org/crap/mt.html ) and reproducing the problem does NOT create any events in the log. The log remains empty after initially clearing it.

Tried it on my iPhone 3GS and my 16GB iPad.

This problem has be independently confirmed on the iPhone and iPad; it definitely is reproducible not only on my devices:
http://twitter.com/#!/mrdoob/statuses/6896165488427008
http://twitter.com/#!/jofreund/statuses/7042266233307136
http://twitter.com/#!/jofreund/statuses/7044667426217985


03-Dec-2010 11:08 PM Patrick Collins :
This bug has been closed as Duplicate. We are aware of and tracking this issue under the Bug ID listed above in the bug State (Duplicate/XXXX). To check the status of the original bug report, please update your report directly <http://bugreport.apple.com> and we will provide you with any available information.

1 decade ago by quake101

Android users, download another browser. Biolab works well with Opera. :)

1 decade ago by wavyGravy

@quake101 Thank you for restoring my faith in browser base games. I have to admit I was bummed out by no multi touch within the browser. I knew Opera was good for something. I will never make fun of Opera again.

1 decade ago by AdamB

Biolab doesn't work at all for me on my Nexus One with Opera.

1 decade ago by AdamB

Whoops, I just realized I was using Opera Mini. I downloaded Opera and it seems to work really well.

1 decade ago by BFresh

+1 on Opera, Mutant Zombie Monsters works well on my phone! Not quite as smooth as on iOS but the multitouch makes it playable.

1 decade ago by StevenFromTexas

I'm a bit late on this discussion, but the default "webkit 3.1" browser on my Android "HTC Inspire" doesn't allow multi-touch either. Also, the game runs a bit choppy.

1 decade ago by fugufish

it's supposed to be choppy (WHAT WHAT? ). On a more serious note, HTML5 does not run good on all mobile browsers. Sound's crappy, FPS is low.

what you can do is to try to create an app instead of letting the game run in the browser. This can be done via frameworks like appMobi. It's basically a highly optimized web browser INSIDE an app. ( kind of defeats the original purpose of HTML5, which was to live independent of any Android Market/App Store apps ). But we're slowly getting there!

search for all the keywords in this post, should get you started. we've had lots of fun discussion abt mobile.

1 decade ago by yatayata

btw mobile firefox seems to be the best performing browser on android right now... in case you want it for a demo/meeting.

1 decade ago by MysteriousStranger

Just wanted to chime in here regarding multi-touch support in the Android browser. Android 4 (Ice Cream Sandwich) has an updated browser that does support multi-touch. I just tested Biolab Disaster on my Galaxy Nexus to confirm this. Sencha has a blog post discussing the new Android browser's HTML5 support here: http://www.sencha.com/blog/galaxy-nexus-the-html5-developer-scorecard/

10 years ago by Didi

I wanted to make touch controls in my android game app. I already found instructions for ios, but for android? any guide lines please? I wanted to do like the biolab disater game.

10 years ago by beakr

Biolab Disaster works great on my Nexus 7 on Jellybean too.

10 years ago by paulh

biolab uses coccoonjs

10 years ago by peardox

The problem with Droid is XSS taint from using file:// URLs

If you test using a local server it'll work perfectly

If running via PhoneGap I've found two important things...

1) Make sure every layer is distance = 1
2) Don't use ig.font

A work-around would be to deploy a local web server and deploy that way but if 1 + 2 are OK for you everything works in my tests to date
Page 1 of 1
« first « previous next › last »